Pay in 4 interest-free payments of $859.37 Learn more
Shipping Estimate
USA
- USA
- CAN
- USA
- CAN
Ships within 48 hours · Estimated delivery Oct 1 - Oct 6
Pay in 4 interest-free payments of $859.37 Learn more
Ships within 48 hours · Estimated delivery Oct 1 - Oct 6
The P1S-2400V-R 400W Server Device Module Power Supply is a reliable and tested component designed to meet the demanding requirements of server environments
brand Generic series NetApp X426A-R6 item_model_number X426A-R6 color Black hard_drive_interface Serial Attached SCSI hard_drive_rotational_speed 10000 RPM manufacturer NetApp asin B0CLT2YW9P date_first_available October 25
1542 BootPRFC 1058 Routing Information ProtocolRFC 1112 IGMP v1RFC 1122 Host requirementsRFC 1256 IPv4 ICMP Router Discovery (IRDP)RFC 1492 TACACS+RFC 1519 Classless Interdomain Routing (CIDR)RFC 1587 OSPF not-so-stubby area (NSSA) OptionRFC 1591 Domain Name System (DNS)RFC 1812 Requirements for IP Version 4 routersRFC 2030 SNTP
Investing in the WD Ultrastar DC HC310 4TB ensures a balance of capacity
nemix ram 256gb ddr5 5600mhz pc5 44800 8rx4 1 1v 288 pin ecc rdimm registered server memory kit compatible with hynix hmct14agera206n server-power-supply The P1S-2400V-R 400W Server DeviceNEMIX RAM memory upgrades compatible with Hynix HMCT14AGERA206N, and backed by a Lifetime Warranty.
US$ 10.00
US$ 14.00
US$ 10301.00
US$ 2558.50
US$ 20.00
US$ 12.50
US$ 24.00
US$ 16.00
US$ 20.00
US$ 20.00
US$ 20.00